Can’t Connect to VPN using ASUS RT-AC66U Router with AdvancedTomato

I need some help. I have an ASUS RT AC66U, I flashed it with AdvancedTomato and put my VPN settings, now the SSID comes up in my devices but it won’t connect. now I have it connected to my main router/modem which is 2 in 1. but I read somewhere if both routers have the same subnet it won’t work, like the main needs to be 192.168.1.1 and the other 192.168.2.1 or something like that. anybody experienced in this? I cant connect when I choose the VPN SSID, but all the settings are correct, and this is a paid VPN service, its VPN unlimited.

in progress 0
TroubleShooting 16 Answers 500 views 0

Answers ( 16 )

  1. Brandt Hoppe
    0

    This could be a number of issues preventing you from authenticating. If you can connect to the SSID and get an IP address then it’s a routing issue between the two devices as you assume. If it’s not getting an IP, check DCHP settings on the WAP. If you can’t authenticate to the SSID at all……then try hard resetting everything and starting over.

  2. Elliot Kulas
    0

    I have unplugged it plenty of times and hate not the issue. It doesn’t connect and it doesn’t get an ip.

    • Valentin
      0

      If you can see the SSID broadcast and can’t connect your problem is the password/Key/Certificate it’s authenticating against, or the encryption time you have set, or a problem with the device at hand.

      Logical troubleshooting would be to try a different laptop/computer/device to connect to it. Or replace the device itself which wouldn’t be easy.

      It’s also possible this VPN device/appliance may require a special setup or software. Check with the OEM of the hardware/software.

  3. Jayce Leannon
    0

    I had this last night maybe similar issue with a TP-Link cable modem using Comcast, same Asus router. Comcast records a MAC address for your router so if you swap it out, I got rid of an older one, the new one won’t work. Gotta hard reset whatever modem you connect with (cable?) and start it back up.

  4. Brendon Hickle
    0

    Log into the second router and set it up as an access point.
    Instructions:  https://www.asus.com/support/FAQ/1005259/

  5. Jalon Weissnat
    0

    Internet Modem WAN IP: XXX.XXX.XXX.XXX | Modem LAN IP 192.168.1.1 to 254 (DHCP) (plug laptop test google.com, it works then ipconfig…then plug the second router instead of the laptop) 2nd Router set local “WAN IP” 192.168.1.2 or in the same subnet than ipconfig result, then set 2nd Router DHCP scope 192.168.10.1 to 254…
    Then you add the VPN, once your network is in working condition… easy… unplug it then

    • Elliot Kulas
      0

      I tried changing the IP address in LAN settings to 192.168.1.2 and the IP range to 192.168.10.1 to 192.168.10.254 I click save and I get this message saying invalid first IP address or subnet mask.

  6. Marcelo Grimes
    0

    Two identical IPs wouldn’t connect if you manually configured it.

    • Elliot Kulas
      0

      Where exactly would I change this? I’m in the LAN tab and I have this. Where it says IP address I would change it to 192.168.1.2? And also where it says IP range do I change it to 192.168.10.1 and 192.168.10.254?

      • Marcelo Grimes
        0

        Check your router’s manual there’s usually a default IP. Are you trying to do peer to peer? What devices? Router to pc? R-R. Btw usually your isp usually provides your static IP.

      • Elliot Kulas
        0

        That is the default IP. I’m trying to change it because both routers can’t have the same IP. And I’m trying to use my other router as VPN router.

        • Marcelo Grimes
          0

          okies then shouldn’t you get your IP to VPN config module.

  7. Elton Welch
    0

    Switch subnet to next one over 192.168.2.1

    • Elliot Kulas
      0

      But where would I do that? As in what settings? Sorry for the trouble I’m new at this. I mean everything is set up right with my VPN configurations but just need to change the VPN router IP since is the same one as my combo router.

      • Elton Welch
        0

        In the LAN settings. Also, the setting has to be of a router, not AP or any other role.

  8. Candido Dibbert
    0

    If it supports it (not all do) put the first router in pass-through mode.

Leave an answer

Click the camera icon to upload an image to your answer. You can upload one image with JPG, GIF or PNG extension and Maximum size of file cannot be more than 2 MB. If you want to add multiple images, paste the direct URLs of images in the answer box.