Answers ( 6 )

    0

    It failed to login. Wrong username, password, port, security token etc, for whatever reason it couldn’t establish a session with the remote host so it exited.

      0

      Alternatively, where you set up the PuTTy session – at the bottom of the window, click the option to never close the window on exit.

        0

        It could also mean that it couldn’t find the home folder. If you set up a network share to c:/fred but there IS no folder called c:/abcd then you cannot access it.

    1

    From the symptoms you describe, it could be a lot of things (bad password, the Linux OOM killer randomly killing your SSH session, wrong permissions on the user’s home directory, and a host of other things). The only way to find out is to read the logs on the server.

    Best answer
      0

      Another way is set PuTTy not to exit on a fail, that way you get to see any error message.

        0

        That would probably be a good idea for debug purposes here, assuming a useful message is displayed.

    1

    There is a setting in PuTTY that controls exit behavior. Close window on exit, and the parameter is only on clean exit. Setting this may provide you with more of a clue as to what is going on when the connection is broken.

    0

    Turn logging on. You have to set the directory where the log file can be written too.

    0

    Anyone suggest a key binding error? I remember one program the “s” key was bound to something and caused an issue. RDP I think was the program.

    1

    Use a Fedora KDE Live DVD and use SSH instead. You can boot it in a VM or literally just put it in your CD-Rom and boot from that. No need to install it at all. It will boot right off the DVD. PuTTy sucks. More details at – https://spins.fedoraproject.org/kde/

Leave an answer

Click the camera icon to upload an image to your answer/comment. One Image - Supported Extensions are JPG, GIF & PNG - Size Maximum - 2 MB. To embed multiple images, add image URLs to the answer/comment.